if you try to connect to SSIS via SSMS this Error Message occurs.

This is if not the correct matching SSMS/SQL Server Engine is used. For example, if you have installed the SSMS 17.9 and try to connect to SSIS 2016 the Error appears.
To fix the Problem, you have to install the correct matching Versions. For this Reason it recommended, if you work with multiple different SQL Server Versions, you should have a SQL Server Management Server in place and on this Server have all SSMS 2014, 16.., 17.., 18.. concurrent installed. It’s a bit ugly but for many other reasons only the correct SSMS in reference to the SQL Server Services have to be used. Especially with the new Versions that will be deployed separated from the SQL Server Installation Sources.

SSIS_Connection_SSMS